Zend certified PHP/Magento developer

How I can get ppp errors/diagnose why the router itself is unable to connect into the internet via VDSL at Fritzbox 7360?

On a Fritzbox 7360 I try to make to connect into the internet via vdsl. My networking settings are:

config interface 'loopback'
    option device 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fdd2:a40d:d919::/48'

config atm-bridge 'atm'
    option vpi '1'
    option vci '32'
    option encaps 'llc'
    option payload 'bridged'
    option nameprefix 'dsl'

config dsl 'dsl'
        option annex 'b'
    option ds_snr_offset '0'
        option line_mode 'vdsl'
        option tone 'auto'

config device
    option name 'br-lan'
    option type 'bridge'
    list ports 'lan1'
    list ports 'lan2'
    list ports 'lan3'
    list ports 'lan4'

config interface 'lan'
    option device 'br-lan'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option ip6assign '60'

config interface 'wan'
    option ifname 'dsl0.835'
        option device 'dsl0'
    option proto 'pppoe'
    option username '^censored^'
    option password '^censored^'
        option ipv6 'auto'

config interface 'wan6'
    option device '@wan'
    option proto 'dhcpv6'

The settings are for Vodafone Greece. In order to perfomr the ppp I tried the following:

ifup wan

That showed no error. After that I tried

ping 8.8.8.8

And I got the following error:

PING 8.8.8.8 (8.8.8.8): 56 data bytes
ping: sendto: Network unreachable

The ping command has been executed via inside the router itself. Also the openwrt has no Lucy at all but an SSH daemon.

The openwrt version is:

NAME="OpenWrt"
VERSION="SNAPSHOT"
ID="openwrt"
ID_LIKE="lede openwrt"
PRETTY_NAME="OpenWrt SNAPSHOT"
VERSION_ID="snapshot"
HOME_URL="https://openwrt.org/"
BUG_URL="https://bugs.openwrt.org/"
SUPPORT_URL="https://forum.openwrt.org/"
BUILD_ID="r17237-7c4d79aa1c"
OPENWRT_BOARD="lantiq/xrx200"
OPENWRT_ARCH="mips_24kc"
OPENWRT_TAINTS=""
OPENWRT_DEVICE_MANUFACTURER="OpenWrt"
OPENWRT_DEVICE_MANUFACTURER_URL="https://openwrt.org/"
OPENWRT_DEVICE_PRODUCT="Generic"
OPENWRT_DEVICE_REVISION="v0"
OPENWRT_RELEASE="OpenWrt SNAPSHOT r17237-7c4d79aa1c"

Any idea why?