Trouble when installing Social Login from Amasty

I’m trying to install a plugin Social Login extension from Amasty on my Magento 2 website, but when I run the command composer require hybridauth/hybridauth ^2.15.1, I get the error:

[user@website]$ composer require hybridauth/hybridauth ^2.15.1
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - The requested package magento/product-community-edition (locked at 2.2.9, required as 2.3.2) is satisfiable by magento/product-community-edition[2.2.9] but these conflict with your requirements or minimum-stability.
  Problem 2
    - Can only install one of: temando/module-shipping-m2[1.5.3, 1.3.11].
    - Can only install one of: temando/module-shipping-m2[1.3.11, 1.5.3].
    - Can only install one of: temando/module-shipping-m2[1.3.11, 1.5.3].
    - magento/product-community-edition 2.3.2 requires temando/module-shipping-m2 1.5.3 -> satisfiable by temando/module-shipping-m2[1.5.3].
    - Installation request for magento/product-community-edition 2.3.2 -> satisfiable by magento/product-community-edition[2.3.2].
    - Installation request for temando/module-shipping-m2 (locked at 1.3.11) -> satisfiable by temando/module-shipping-m2[1.3.11].


Installation failed, reverting ./composer.json to its original content.

I have Magento v2.2.9, PHP v7.1.33.